summaryrefslogtreecommitdiff
path: root/dev-libs/ibpp/files
Unidiff
Diffstat (limited to 'dev-libs/ibpp/files') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/ibpp/files/digest-ibpp-2.3.5.03
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch30
-rw-r--r--dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch21
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/ibpp/files/digest-ibpp-2.3.5.0 b/dev-libs/ibpp/files/digest-ibpp-2.3.5.0
new file mode 100644
index 0000000..62f93d1
--- a/dev/null
+++ b/dev-libs/ibpp/files/digest-ibpp-2.3.5.0
@@ -0,0 +1,3 @@
1MD5 f96991555dec3c98216e0d78f31b8586 ibpp-2-3-5-0-src.zip 126081
2RMD160 02226aabc07177b4b24595667301b5d39cc483b2 ibpp-2-3-5-0-src.zip 126081
3SHA256 422a72596f933ab81a9097dcf3d6ad275bf148ea260a15e68456fa1ad01e0eed ibpp-2-3-5-0-src.zip 126081
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
new file mode 100644
index 0000000..6823ca6
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-CXXFLAGS.patch
@@ -0,0 +1,30 @@
1diff -Naur ibpp.orig/Makefile ibpp/Makefile
2 --- ibpp.orig/Makefile2004-09-27 14:08:44.000000000 -0400
3 +++ ibpp/Makefile2005-09-16 02:44:37.000000000 -0400
4@@ -164,20 +164,19 @@
5 # building on linux (any flavour, I suppose)
6 ifeq ($(PLATFORM),linux)
7 CXXOUTPUT =-o
8 -CXXFLAGS =-DIBPP_LINUX
9 -CXXFLAGS+=-DIBPP_GCC
10 -CXXFLAGS+=-I./ -I./fbheaders
11 #
12 # change -lfbclient by -lgds if building with Firebird 1.x or InterBase
13 # -lfbclient (or -lgds) is for Firebird 1.5 SS and higher
14 # -lfbembed is for Firebird 1.5 CS and higher
15 #
16 LIBS+=-lfbclient -lcrypt -lm -ldl -lpthread # dependancies for shared library
17 -ifeq ($(TARGETDIR),release)
18 - CXXFLAGS+= -O3
19 -else
20 - CXXFLAGS+= -g -DDEBUG -Wall
21 +ifeq ($(TARGETDIR),debug)
22 + CXXFLAGS=-g -DDEBUG -Wall
23 endif
24 +CXXFLAGS+=-fPIC
25 +CXXFLAGS+=-DIBPP_LINUX
26 +CXXFLAGS+=-DIBPP_GCC
27 +CXXFLAGS+=-I./ -I./fbheaders
28 #
29 TARGETS =$(TARGETDIR)/$(PLATFORM)/libibpp.a \
30 $(TARGETDIR)/$(PLATFORM)/libibpp.so \
diff --git a/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch b/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch
new file mode 100644
index 0000000..283a46b
--- a/dev/null
+++ b/dev-libs/ibpp/files/ibpp-2.3.5.0-amd64.patch
@@ -0,0 +1,21 @@
1diff -Naur ibpp.orig/array.cpp ibpp/array.cpp
2 --- ibpp.orig/array.cpp2004-09-23 17:34:08.000000000 +0200
3 +++ ibpp/array.cpp2004-10-25 22:51:01.000000000 +0200
4@@ -289,7 +289,7 @@
5 throw ExceptionImpl("Array::ReadTo", "Wrong count of array elements");
6
7 IBS status;
8 -long lenbuf = mBufferSize;
9 +ISC_LONG lenbuf = mBufferSize;
10 (*gds.Call()->m_array_get_slice)(status.Self(), mDatabase->GetHandlePtr(),
11 mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
12 if (status.Errors())
13@@ -1088,7 +1088,7 @@
14 }
15
16 IBS status;
17 -long lenbuf = mBufferSize;
18 +ISC_LONG lenbuf = mBufferSize;
19 (*gds.Call()->m_array_put_slice)(status.Self(), mDatabase->GetHandlePtr(),
20 mTransaction->GetHandlePtr(), &mId, &mDesc, mBuffer, &lenbuf);
21 if (status.Errors())