summaryrefslogtreecommitdiff
path: root/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
Side-by-side diff
Diffstat (limited to 'net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff') (more/less context) (ignore whitespace changes)
-rw-r--r--net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff161
1 files changed, 161 insertions, 0 deletions
diff --git a/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff b/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
new file mode 100644
index 0000000..0770d1c
--- a/dev/null
+++ b/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
@@ -0,0 +1,161 @@
+diff -Nur foo2zjs.orig/Makefile foo2zjs/Makefile
+--- foo2zjs.orig/Makefile 2007-02-19 23:27:10.000000000 +0100
++++ foo2zjs/Makefile 2007-02-19 23:26:56.000000000 +0100
+@@ -7,7 +7,7 @@
+
+ # Installation prefix...
+ PREFIX=/usr/local
+-PREFIX=/usr
++PREFIX=$(DESTDIR)/usr
+
+ # Pathnames for this package...
+ BIN=$(PREFIX)/bin
+@@ -20,7 +20,7 @@
+ DOCDIR=$(PREFIX)/share/doc/foo2zjs/
+
+ # Pathnames for referenced packages...
+-FOODB=/usr/share/foomatic/db/source
++FOODB=$(PREFIX)/share/foomatic/db/source
+
+ # User ID's
+ LPuid=-olp
+@@ -180,7 +180,7 @@
+ endif
+
+ # Compiler flags
+-CFLAGS += -O2 -Wall
++CFLAGS ?= -O2 -Wall
+
+ #
+ # Rules to create test documents
+@@ -368,12 +368,14 @@
+
+
+ install-prog:
++ [ -d $(BIN) ] || install -d -m 755 $(BIN)/
++ [ -d $(DESTDIR)/bin/ ] || install -d -m 755 $(DESTDIR)/bin/
+ #
+ # Install driver, wrapper, and development tools
+ #
+ install -c $(PROGS) $(SHELLS) $(BIN)/
+ if [ "$(BINPROGS)" != "" ]; then \
+- install -c $(BINPROGS) /bin/; \
++ install -c $(BINPROGS) $(DESTDIR)/bin/; \
+ fi
+ #
+ # Install gamma correction files. These are just templates,
+@@ -401,6 +403,7 @@
+ #
+ @if [ -d $(FOODB) ]; then \
+ for dir in driver printer opt; do \
++ [ -d $(FOODB)/$$dir/ ] || install -d -m 755 $(FOODB)/$$dir/; \
+ echo install -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
+ install -c -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
+ done \
+@@ -418,10 +421,10 @@
+ #
+ # Clear foomatic cache and rebuild database if needed
+ #
+- rm -rf /var/cache/foomatic/*/*
+- rm -f /var/cache/foomatic/printconf.pickle
+- if [ -d /var/cache/foomatic/compiled ]; then \
+- cd /var/cache/foomatic/compiled; \
++ rm -rf $(DESTDIR)/var/cache/foomatic/*/*
++ rm -f $(DESTDIR)/var/cache/foomatic/printconf.pickle
++ if [ -d $(DESTDIR)/var/cache/foomatic/compiled ]; then \
++ cd $(DESTDIR)/var/cache/foomatic/compiled; \
+ foomatic-combo-xml -O >overview.xml; \
+ fi
+
+@@ -492,18 +495,12 @@
+ fi; \
+ done
+
+-MODEL=/usr/share/cups/model
+-LOCALMODEL=/usr/local/share/cups/model
++MODEL=$(PREFIX)/share/cups/model
++#LOCALMODEL=/usr/local/share/cups/model
+ install-ppd:
+ #
+ # Install PPD files for CUPS
+ #
+- if [ -d /usr/share/ppd/ ]; then \
+- find /usr/share/ppd/ -name '*foo2zjs*' | xargs rm -f; \
+- find /usr/share/ppd/ -name '*foo2hp*' | xargs rm -f; \
+- find /usr/share/ppd/ -name '*foo2xqx*' | xargs rm -f; \
+- find /usr/share/ppd/ -name '*foo2lava*' | xargs rm -f; \
+- fi
+ if [ -d $(MODEL) ]; then \
+ cd PPD; \
+ for ppd in *.ppd; do \
+@@ -516,10 +513,8 @@
+ done; \
+ fi
+
+-USBDIR=/etc/hotplug/usb
+-UDEVDIR=/etc/udev/rules.d
+-RULES=hplj10xx.rules
+-install-hotplug: install-hotplug-test install-hotplug-prog
++USBDIR=$(DESTDIR)/etc/hotplug/usb
++install-hotplug: install-hotplug-test install-udev
+
+ install-hotplug-test:
+ #
+@@ -537,18 +532,18 @@
+ #
+
+ install-hotplug-prog:
+- if [ -d $(UDEVDIR) ]; then \
+- install -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES); \
+- fi
+ [ -d $(USBDIR) ] || install -d -m 755 $(USBDIR)/
+ install -c -m 755 hplj1000 $(USBDIR)/
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1005
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1018
+ ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1020
+- $(USBDIR)/hplj1000 install-usermap
+- $(USBDIR)/hplj1005 install-usermap
+- $(USBDIR)/hplj1018 install-usermap
+- $(USBDIR)/hplj1020 install-usermap
++ install -c -m 644 hplj.usermap $(USBDIR)/
++
++UDEVDIR=$(DESTDIR)/etc/udev/rules.d
++RULES=hplj10xx.rules
++install-udev:
++ [ -d $(UDEVDIR) ] || install -d -m 755 $(UDEVDIR)/
++ install -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES)
+
+ cups: FRC
+ if [ -x /etc/init.d/cups ]; then \
+@@ -862,7 +857,6 @@
+ install -c -m 644 README $(DOCDIR)
+ install -c -m 644 ChangeLog $(DOCDIR)
+
+-GROFF=/usr/local/test/bin/groff
+ GROFF=groff
+ manual.pdf: $(MANPAGES)
+ -$(GROFF) -t -man $(MANPAGES) | ps2pdf - $@
+diff -Nur foo2zjs.orig/hplj.usermap foo2zjs/hplj.usermap
+--- foo2zjs.orig/hplj.usermap 1970-01-01 01:00:00.000000000 +0100
++++ foo2zjs/hplj.usermap 2007-02-19 23:26:08.000000000 +0100
+@@ -0,0 +1,4 @@
++hplj1000 0x0003 0x03f0 0x0517 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
++hplj1005 0x0003 0x03f0 0x1317 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
++hplj1018 0x0003 0x03f0 0x4117 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
++hplj1020 0x0003 0x03f0 0x2b17 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
+diff -Nur foo2zjs.orig/icc2ps/Makefile foo2zjs/icc2ps/Makefile
+--- foo2zjs.orig/icc2ps/Makefile 2007-02-19 23:27:10.000000000 +0100
++++ foo2zjs/icc2ps/Makefile 2007-02-19 23:26:08.000000000 +0100
+@@ -1,10 +1,10 @@
+-PREFIX= /usr
++PREFIX= $(DESTDIR)/usr
+ BIN= $(PREFIX)/bin
+ SRC= icc2ps.c xgetopt.c
+ LIB= cmscam97.c cmscnvrt.c cmserr.c cmsgamma.c cmsgmt.c cmsintrp.c cmsio1.c \
+ cmslut.c cmsmatsh.c cmsmtrx.c cmsnamed.c cmspack.c cmspcs.c cmsps2.c \
+ cmssamp.c cmswtpnt.c cmsxform.c cmsio0.c cmsvirt.c
+-CFLAGS= -O3
++CFLAGS?= -O3
+
+ all: foo2zjs-icc2ps
+