summaryrefslogtreecommitdiff
path: root/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
Unidiff
Diffstat (limited to 'net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff') (more/less context) (ignore whitespace changes)
-rw-r--r--net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff161
1 files changed, 161 insertions, 0 deletions
diff --git a/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff b/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
new file mode 100644
index 0000000..0770d1c
--- a/dev/null
+++ b/net-print/foo2zjs/files/foo2zjs-Makefile-20070204.diff
@@ -0,0 +1,161 @@
1diff -Nur foo2zjs.orig/Makefile foo2zjs/Makefile
2 --- foo2zjs.orig/Makefile2007-02-19 23:27:10.000000000 +0100
3 +++ foo2zjs/Makefile2007-02-19 23:26:56.000000000 +0100
4@@ -7,7 +7,7 @@
5
6 # Installation prefix...
7 PREFIX=/usr/local
8-PREFIX=/usr
9+PREFIX=$(DESTDIR)/usr
10
11 # Pathnames for this package...
12 BIN=$(PREFIX)/bin
13@@ -20,7 +20,7 @@
14 DOCDIR=$(PREFIX)/share/doc/foo2zjs/
15
16 # Pathnames for referenced packages...
17-FOODB=/usr/share/foomatic/db/source
18+FOODB=$(PREFIX)/share/foomatic/db/source
19
20 # User ID's
21 LPuid=-olp
22@@ -180,7 +180,7 @@
23 endif
24
25 # Compiler flags
26 -CFLAGS +=-O2 -Wall
27+CFLAGS ?= -O2 -Wall
28
29 #
30 # Rules to create test documents
31@@ -368,12 +368,14 @@
32
33
34 install-prog:
35 +[ -d $(BIN) ] || install -d -m 755 $(BIN)/
36 +[ -d $(DESTDIR)/bin/ ] || install -d -m 755 $(DESTDIR)/bin/
37 #
38 # Install driver, wrapper, and development tools
39 #
40 install -c $(PROGS) $(SHELLS) $(BIN)/
41 if [ "$(BINPROGS)" != "" ]; then \
42 - install -c $(BINPROGS) /bin/; \
43 + install -c $(BINPROGS) $(DESTDIR)/bin/; \
44 fi
45 #
46 # Install gamma correction files. These are just templates,
47@@ -401,6 +403,7 @@
48 #
49 @if [ -d $(FOODB) ]; then \
50 for dir in driver printer opt; do \
51 + [ -d $(FOODB)/$$dir/ ] || install -d -m 755 $(FOODB)/$$dir/; \
52 echo install -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
53 install -c -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
54 done \
55@@ -418,10 +421,10 @@
56 #
57 # Clear foomatic cache and rebuild database if needed
58 #
59 -rm -rf /var/cache/foomatic/*/*
60 -rm -f /var/cache/foomatic/printconf.pickle
61 -if [ -d /var/cache/foomatic/compiled ]; then \
62 - cd /var/cache/foomatic/compiled; \
63 +rm -rf $(DESTDIR)/var/cache/foomatic/*/*
64 +rm -f $(DESTDIR)/var/cache/foomatic/printconf.pickle
65 +if [ -d $(DESTDIR)/var/cache/foomatic/compiled ]; then \
66 + cd $(DESTDIR)/var/cache/foomatic/compiled; \
67 foomatic-combo-xml -O >overview.xml; \
68 fi
69
70@@ -492,18 +495,12 @@
71 fi; \
72 done
73
74-MODEL=/usr/share/cups/model
75-LOCALMODEL=/usr/local/share/cups/model
76+MODEL=$(PREFIX)/share/cups/model
77+#LOCALMODEL=/usr/local/share/cups/model
78 install-ppd:
79 #
80 # Install PPD files for CUPS
81 #
82 -if [ -d /usr/share/ppd/ ]; then \
83 - find /usr/share/ppd/ -name '*foo2zjs*' | xargs rm -f; \
84 - find /usr/share/ppd/ -name '*foo2hp*' | xargs rm -f; \
85 - find /usr/share/ppd/ -name '*foo2xqx*' | xargs rm -f; \
86 - find /usr/share/ppd/ -name '*foo2lava*' | xargs rm -f; \
87 -fi
88 if [ -d $(MODEL) ]; then \
89 cd PPD; \
90 for ppd in *.ppd; do \
91@@ -516,10 +513,8 @@
92 done; \
93 fi
94
95-USBDIR=/etc/hotplug/usb
96-UDEVDIR=/etc/udev/rules.d
97-RULES=hplj10xx.rules
98-install-hotplug: install-hotplug-test install-hotplug-prog
99+USBDIR=$(DESTDIR)/etc/hotplug/usb
100+install-hotplug: install-hotplug-test install-udev
101
102 install-hotplug-test:
103 #
104@@ -537,18 +532,18 @@
105 #
106
107 install-hotplug-prog:
108 -if [ -d $(UDEVDIR) ]; then \
109 - install -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES); \
110 -fi
111 [ -d $(USBDIR) ] || install -d -m 755 $(USBDIR)/
112 install -c -m 755 hplj1000 $(USBDIR)/
113 ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1005
114 ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1018
115 ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1020
116 -$(USBDIR)/hplj1000 install-usermap
117 -$(USBDIR)/hplj1005 install-usermap
118 -$(USBDIR)/hplj1018 install-usermap
119 -$(USBDIR)/hplj1020 install-usermap
120 +install -c -m 644 hplj.usermap $(USBDIR)/
121+
122+UDEVDIR=$(DESTDIR)/etc/udev/rules.d
123+RULES=hplj10xx.rules
124+install-udev:
125 +[ -d $(UDEVDIR) ] || install -d -m 755 $(UDEVDIR)/
126 +install -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES)
127
128 cups:FRC
129 if [ -x /etc/init.d/cups ]; then \
130@@ -862,7 +857,6 @@
131 install -c -m 644 README $(DOCDIR)
132 install -c -m 644 ChangeLog $(DOCDIR)
133
134-GROFF=/usr/local/test/bin/groff
135 GROFF=groff
136 manual.pdf: $(MANPAGES)
137 -$(GROFF) -t -man $(MANPAGES) | ps2pdf - $@
138diff -Nur foo2zjs.orig/hplj.usermap foo2zjs/hplj.usermap
139 --- foo2zjs.orig/hplj.usermap1970-01-01 01:00:00.000000000 +0100
140 +++ foo2zjs/hplj.usermap2007-02-19 23:26:08.000000000 +0100
141@@ -0,0 +1,4 @@
142+hplj1000 0x0003 0x03f0 0x0517 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
143+hplj1005 0x0003 0x03f0 0x1317 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
144+hplj1018 0x0003 0x03f0 0x4117 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
145+hplj1020 0x0003 0x03f0 0x2b17 0x0000 0x0000 0x00 0x00 0x00 0x00 0x00 0x00 0x00000000
146diff -Nur foo2zjs.orig/icc2ps/Makefile foo2zjs/icc2ps/Makefile
147 --- foo2zjs.orig/icc2ps/Makefile2007-02-19 23:27:10.000000000 +0100
148 +++ foo2zjs/icc2ps/Makefile2007-02-19 23:26:08.000000000 +0100
149@@ -1,10 +1,10 @@
150 -PREFIX=/usr
151 +PREFIX=$(DESTDIR)/usr
152 BIN=$(PREFIX)/bin
153 SRC=icc2ps.c xgetopt.c
154 LIB=cmscam97.c cmscnvrt.c cmserr.c cmsgamma.c cmsgmt.c cmsintrp.c cmsio1.c \
155 cmslut.c cmsmatsh.c cmsmtrx.c cmsnamed.c cmspack.c cmspcs.c cmsps2.c \
156 cmssamp.c cmswtpnt.c cmsxform.c cmsio0.c cmsvirt.c
157 -CFLAGS=-O3
158 +CFLAGS?=-O3
159
160 all: foo2zjs-icc2ps
161