summaryrefslogtreecommitdiff
path: root/www-misc/mergelog/mergelog-4.5.ebuild
Side-by-side diff
Diffstat (limited to 'www-misc/mergelog/mergelog-4.5.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--www-misc/mergelog/mergelog-4.5.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/www-misc/mergelog/mergelog-4.5.ebuild b/www-misc/mergelog/mergelog-4.5.ebuild
index 3944793..e3c14e7 100644
--- a/www-misc/mergelog/mergelog-4.5.ebuild
+++ b/www-misc/mergelog/mergelog-4.5.ebuild
@@ -1,18 +1,31 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/mergelog/mergelog-4.5.ebuild,v 1.3 2006/10/28 11:03:32 tomk Exp $
+# $Header: $
+
+inherit eutils autotools
DESCRIPTION="A utility to merge apache logs in chronological order"
SRC_URI="mirror://sourceforge/mergelog/${P}.tar.gz"
HOMEPAGE="http://mergelog.sourceforge.net"
-IUSE=""
+IUSE="splitlog"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ppc ~amd64"
-DEPEND="virtual/libc"
-RDEPEND=""
+DEPEND="
+ virtual/libc
+ splitlog? ( sys-devel/autoconf )
+"
+
+src_unpack() {
+ unpack $A
+ cd $S
+ if use splitlog ; then
+ epatch ${FILESDIR}/${PN}-split.patch
+ eautoreconf
+ fi
+}
src_compile() {
econf || die "configure failed"