summaryrefslogtreecommitdiff
path: root/x11-plugins/asmem/files/asmem-1.12-gentoo.patch
Side-by-side diff
Diffstat (limited to 'x11-plugins/asmem/files/asmem-1.12-gentoo.patch') (more/less context) (ignore whitespace changes)
-rw-r--r--x11-plugins/asmem/files/asmem-1.12-gentoo.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/asmem/files/asmem-1.12-gentoo.patch b/x11-plugins/asmem/files/asmem-1.12-gentoo.patch
new file mode 100644
index 0000000..9a59ae0
--- a/dev/null
+++ b/x11-plugins/asmem/files/asmem-1.12-gentoo.patch
@@ -0,0 +1,35 @@
+--- autoconf/Makefile.common.in.orig 1999-03-07 14:12:42.000000000 +0100
++++ autoconf/Makefile.common.in 2006-09-12 00:01:00.000000000 +0200
+@@ -9,11 +9,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROG)
+- $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man $(DESTDIR)$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+--- autoconf/Makefile.defines.in.orig 2000-06-16 16:01:50.000000000 +0200
++++ autoconf/Makefile.defines.in 2006-09-12 00:01:33.000000000 +0200
+@@ -2,6 +2,7 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
+@@ -22,7 +23,7 @@
+ INSTALL_MODE = @INSTALL_MODE@
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL@ -s @INSTALL_MODE@
++INSTALL_PROGRAM = @INSTALL@ -m 755 @INSTALL_MODE@
+ INSTALL_DATA = @INSTALL@ -m 644
+
+ INCS_X = @X_CFLAGS@