summaryrefslogtreecommitdiff
path: root/noncore/multimedia/opieplayer2/audiowidget.cpp
AgeCommit message (Expand)AuthorFilesLines
2004-05-12- convert qDebug to odebugar1-5/+5
2004-04-04use odebug classesmickeyl1-1/+4
2004-04-04convert to Opie Debugging Frameworkmickeyl1-4/+4
2004-03-14Use ODP namespacezecke1-0/+1
2004-03-02fix includeschicken1-2/+0
2004-03-02applied the patch generated by the optimize_connect script fromalwin1-1/+1
2004-02-19fix compile problem reported by Brad Campbell - Thanksar1-1/+1
2004-02-14improve support for BigScreenar1-1/+3
2003-08-09Merge from BRANCH_1_0kergoth1-15/+1
2002-12-14- kill the flickery when painting. backgroundmode is now alwayssimon1-2/+0
2002-12-11- collect arguments passed to the skin loading into a structuresimon1-8/+3
2002-12-11- expose information about the buttonssimon1-1/+11
2002-12-11- ah, forgot to remove this unused codesimon1-19/+0
2002-12-11- less code duplication. code from resizeEvent is now shared as well assimon1-11/+2
2002-12-11- centralize more of the skin loading code, so it can be factored out latersimon1-12/+1
2002-12-11- moved the shared button up/down image variables into the base classsimon1-7/+7
2002-12-09- hah, the improved design pays off :) switching skins at run-time nowsimon1-40/+43
2002-12-09- the skin loading code is now centralized. no more duplicated code :)simon1-24/+1
2002-12-09- minor cleanupsimon1-5/+0
2002-12-09- reworked the mouse event handling to be much simplersimon1-0/+8
2002-12-09- another small cleanup in the mouse handlingsimon1-10/+0
2002-12-09- yay, mouseMoveEvent is no more duplicated code :)simon1-45/+0
2002-12-09- more cleanups in the mouse event handlersimon1-4/+2
2002-12-09- less indexingsimon1-4/+6
2002-12-09- back to a vector :Psimon1-3/+4
2002-12-09- less indexing in the mouse event handlersimon1-11/+14
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon1-3/+3
2002-12-09- merged duplicated setToggleButton methodsimon1-8/+0
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon1-19/+0
2002-12-09- pixBg is now backgroundPixmap and shared in the base classsimon1-6/+6
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon1-11/+2
2002-12-09- migrating from a button vector to a button mapsimon1-5/+5
2002-12-09- merged the two button setup loopssimon1-10/+8
2002-12-09- merged the separate mask and pixmap arrays into the Button structuresimon1-15/+10
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon1-2/+2
2002-12-09- re-organizing a bit the button storage. more to come.simon1-21/+21
2002-12-09- isToggle is now an enum ButtonType { NormalButton, ToggleButton };simon1-6/+4
2002-12-09- another hardcoded number removed :)simon1-1/+1
2002-12-09- buttonPixUp/Down are now vectors, toosimon1-15/+7
2002-12-09- use a vector to store the maskssimon1-10/+9
2002-12-09- one global variable lesssimon1-4/+3
2002-12-09- Key_Space triggers togglePaused()simon1-9/+1
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon1-8/+0
2002-12-08- some preparations for further code cleanups for paintButton callssimon1-6/+6
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon1-6/+1
2002-12-08- merged xoff/yoff into a QPointe member variable, shared in the base classsimon1-7/+7
2002-12-08- share the imgButtonMask member variable in the base classsimon1-6/+6
2002-12-08- share the buttons data in a buttons member variable in the base classsimon1-25/+25
2002-12-08- unused variables removedsimon1-22/+0
2002-12-08- made audioButtons a member variable here, toosimon1-4/+24