summaryrefslogtreecommitdiff
path: root/noncore/multimedia/opieplayer2/videowidget.cpp
AgeCommit message (Expand)AuthorFilesLines
2004-09-23-Remove bogus whitespaceszecke1-1/+2
2004-03-02fix includeschicken1-2/+0
2004-03-02applied the patch generated by the optimize_connect script fromalwin1-2/+2
2003-08-09Merge from BRANCH_1_0kergoth1-12/+2
2002-12-14- kill the flickery when painting. backgroundmode is now alwayssimon1-4/+0
2002-12-11- set the correct status on the fullscreen toggle button when returningsimon1-0/+1
2002-12-11- collect arguments passed to the skin loading into a structuresimon1-8/+3
2002-12-11- expose information about the buttonssimon1-1/+11
2002-12-11- less code duplication. code from resizeEvent is now shared as well assimon1-30/+2
2002-12-11- centralize more of the skin loading code, so it can be factored out latersimon1-10/+1
2002-12-11- moved the shared button up/down image variables into the base classsimon1-7/+7
2002-12-09- hah, the improved design pays off :) switching skins at run-time nowsimon1-20/+27
2002-12-09- the skin loading code is now centralized. no more duplicated code :)simon1-24/+1
2002-12-09- minor cleanupsimon1-8/+2
2002-12-09- another small cleanup in the mouse handlingsimon1-5/+1
2002-12-09- another global variable removedsimon1-3/+1
2002-12-09- yay, mouseMoveEvent is no more duplicated code :)simon1-40/+0
2002-12-09- removing duplicated code in VideoWidgetsimon1-24/+1
2002-12-09- more cleanups in the mouse event handlersimon1-3/+2
2002-12-09- transition to MediaWidget::Command completedsimon1-15/+18
2002-12-09- starting to migrate the videowidget to MediaWidget::Command and friendssimon1-20/+20
2002-12-09- less hardcoding of numberssimon1-4/+5
2002-12-09- back to a vector :Psimon1-8/+8
2002-12-09- less indexing in the mouse event handlersimon1-12/+15
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon1-7/+7
2002-12-09- merged duplicated setToggleButton methodsimon1-6/+0
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon1-31/+0
2002-12-09- pixBg is now backgroundPixmap and shared in the base classsimon1-7/+7
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon1-13/+2
2002-12-09- getting rid of the buttonPixUp/Down arrays, reuse the Button structuresimon1-20/+12
2002-12-09- get rid of the masks array and re-use the Button structuresimon1-12/+10
2002-12-09- migrating from a button vector to a button mapsimon1-11/+10
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon1-2/+2
2002-12-09- isToggle is now an enum ButtonType { NormalButton, ToggleButton };simon1-5/+3
2002-12-08- synchronizing the button indices a bit more with the audiowidgetsimon1-3/+3
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon1-6/+0
2002-12-08- some preparations for further code cleanups for paintButton callssimon1-6/+6
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon1-6/+1
2002-12-08- merged xoff/yoff into a QPointe member variable, shared in the base classsimon1-8/+8
2002-12-08- share the imgButtonMask member variable in the base classsimon1-6/+6
2002-12-08- share the buttons data in a buttons member variable in the base classsimon1-21/+21
2002-12-08- unused variables removedsimon1-14/+0
2002-12-08- made videoButtons a member variable instead of a global onesimon1-4/+21
2002-12-08- merged duplicated MediaButton definition into common MediaWidget::Buttonsimon1-7/+2
2002-12-08- minor cleanupsimon1-5/+7
2002-12-02- yay, last singleton gone. global playList variable is no more :)simon1-7/+5
2002-12-02- replaced QPixmap and QImage pointer usage with value usagesimon1-21/+17
2002-12-02- centralized closeEvent implementationsimon1-5/+0
2002-12-02- the audiowidget and the videowidget don't rely on the mediaplayerstatesimon1-38/+37
2002-12-02- less header inclusionssimon1-1/+0