Age | Commit message (Expand) | Author | Files | Lines |
2002-12-10 | moving to playlistview after adding to it is annoying some people and me some... | llornkcor | 1 | -2/+6 |
2002-12-10 | - added ThreadUtil::Thread class | simon | 2 | -0/+127 |
2002-12-09 | - ok, next try for that allocator. stupid gcc2 :( | simon | 1 | -1/+12 |
2002-12-09 | - work around gcc2's stupid STL that requires libstdc++ in the default | simon | 1 | -3/+7 |
2002-12-09 | - removed unused isHeld attribute | simon | 1 | -2/+1 |
2002-12-09 | - hah, the improved design pays off :) switching skins at run-time now | simon | 9 | -61/+87 |
2002-12-09 | - the skin loading code is now centralized. no more duplicated code :) | simon | 4 | -48/+50 |
2002-12-09 | - minor cleanup | simon | 4 | -15/+2 |
2002-12-09 | - reworked the mouse event handling to be much simpler | simon | 4 | -47/+51 |
2002-12-09 | - another small cleanup in the mouse handling | simon | 6 | -18/+13 |
2002-12-09 | - apparently gcc2 is too stupid to grok this :-( | simon | 1 | -1/+1 |
2002-12-09 | - another global variable removed | simon | 2 | -3/+3 |
2002-12-09 | - yay, mouseMoveEvent is no more duplicated code :) | simon | 6 | -91/+50 |
2002-12-09 | - removing duplicated code in VideoWidget | simon | 4 | -27/+9 |
2002-12-09 | - more cleanups in the mouse event handler | simon | 2 | -7/+4 |
2002-12-09 | - less indexing | simon | 1 | -4/+6 |
2002-12-09 | - transition to MediaWidget::Command completed | simon | 5 | -28/+30 |
2002-12-09 | - starting to migrate the videowidget to MediaWidget::Command and friends | simon | 2 | -21/+21 |
2002-12-09 | - less hardcoding of numbers | simon | 1 | -4/+5 |
2002-12-09 | - back to a vector :P | simon | 4 | -17/+19 |
2002-12-09 | - less indexing in the mouse event handler | simon | 2 | -23/+29 |
2002-12-09 | - toggleButton and setToggleButton now operate on a Button object instead | simon | 5 | -23/+17 |
2002-12-09 | - merged duplicated setToggleButton method | simon | 6 | -17/+12 |
2002-12-09 | - minor cleanup in paintEvent | simon | 2 | -5/+10 |
2002-12-09 | - minor cleanup | simon | 2 | -5/+8 |
2002-12-09 | - merged the duplicated (and identical) paintEvent methods into the | simon | 6 | -52/+30 |
2002-12-09 | - pixBg is now backgroundPixmap and shared in the base class | simon | 5 | -15/+15 |
2002-12-09 | - paintButton is no more a duplicated method but centralized in the | simon | 6 | -28/+14 |
2002-12-09 | - removed unused pixmaps array | simon | 1 | -1/+0 |
2002-12-09 | - getting rid of the buttonPixUp/Down arrays, reuse the Button structure | simon | 2 | -22/+12 |
2002-12-09 | - get rid of the masks array and re-use the Button structure | simon | 2 | -14/+10 |
2002-12-09 | - migrating from a button vector to a button map | simon | 3 | -17/+18 |
2002-12-09 | - merged the two button setup loops | simon | 1 | -10/+8 |
2002-12-09 | - merged the separate mask and pixmap arrays into the Button structure | simon | 2 | -19/+15 |
2002-12-09 | - moving some variables to the base class | simon | 2 | -6/+7 |
2002-12-09 | - oops, buttonType is a bad name for a variable, given its redundancy | simon | 3 | -7/+7 |
2002-12-09 | - re-organizing a bit the button storage. more to come. | simon | 2 | -21/+28 |
2002-12-09 | - isToggle is now an enum ButtonType { NormalButton, ToggleButton }; | simon | 3 | -13/+10 |
2002-12-09 | - another hardcoded number removed :) | simon | 1 | -1/+1 |
2002-12-09 | - buttonPixUp/Down are now vectors, too | simon | 2 | -18/+10 |
2002-12-09 | - use a vector to store the masks | simon | 2 | -11/+12 |
2002-12-09 | - one global variable less | simon | 2 | -4/+4 |
2002-12-09 | switch (mouse) { | simon | 1 | -4/+4 |
2002-12-09 | - replaced currentFileListView method with a variable | simon | 2 | -17/+12 |
2002-12-09 | - use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE and | simon | 3 | -8/+4 |
2002-12-09 | - Key_Space triggers togglePaused() | simon | 1 | -9/+1 |
2002-12-08 | - synchronizing the button indices a bit more with the audiowidget | simon | 2 | -6/+6 |
2002-12-08 | - merged the two duplicated toggleButton methods into a shared one | simon | 6 | -17/+9 |
2002-12-08 | - oops, forgot to commit this one | simon | 1 | -0/+6 |
2002-12-08 | - some preparations for further code cleanups for paintButton calls | simon | 5 | -14/+17 |