Age | Commit message (Expand) | Author | Files | Lines |
2002-12-12 | moved readM3u and readPls to one function. fixed pls. more to come | llornkcor | 3 | -102/+101 |
2002-12-11 | buttons centered again | harlekin | 1 | -29/+29 |
2002-12-11 | - skins are now pre-loaded in the background (step by step) | simon | 5 | -31/+148 |
2002-12-11 | - make the cache work as expected | simon | 1 | -4/+35 |
2002-12-11 | - SkinCache now operates on SkinData instead of single images | simon | 2 | -21/+18 |
2002-12-11 | - disable cache temporarily | simon | 2 | -4/+11 |
2002-12-11 | valgrind complained and here are some off-by-1 fixes | sandman | 1 | -3/+4 |
2002-12-11 | - moved the skin cache into the .cpp file | simon | 2 | -16/+16 |
2002-12-11 | - set the correct status on the fullscreen toggle button when returning | simon | 1 | -0/+1 |
2002-12-11 | - restructing a bit the skin data storage, in preparation for cache | simon | 2 | -27/+41 |
2002-12-11 | - copyright notice fixlet | simon | 5 | -15/+76 |
2002-12-11 | - collect arguments passed to the skin loading into a structure | simon | 6 | -24/+24 |
2002-12-11 | - added a skin cache and a threaded skin loader. looks like the latter | simon | 3 | -4/+155 |
2002-12-11 | - expose information about the buttons | simon | 4 | -2/+28 |
2002-12-11 | - ah, forgot to remove this unused code | simon | 1 | -19/+0 |
2002-12-11 | - roll back the threaded xine initialization, the mediaplayer initialization | simon | 11 | -241/+84 |
2002-12-11 | - less code duplication. code from resizeEvent is now shared as well as | simon | 4 | -41/+42 |
2002-12-11 | - moved default skin name reading over to skin class | simon | 3 | -10/+26 |
2002-12-11 | - minor cleanup | simon | 2 | -7/+5 |
2002-12-11 | - oops, do the right cast in the gamma set method | simon | 1 | -1/+1 |
2002-12-11 | - slight simplification in the API | simon | 4 | -12/+11 |
2002-12-11 | - button mask composing moved to Skin class | simon | 4 | -27/+41 |
2002-12-11 | - starting with skin preloading | simon | 2 | -6/+37 |
2002-12-11 | - moved the remaining pieces of image/pixmap loading to the Skin class | simon | 4 | -16/+23 |
2002-12-11 | - more image loading functionality moved to the Skin class | simon | 3 | -2/+17 |
2002-12-11 | - starting to factor out the actual skin image loading into a separate | simon | 4 | -3/+48 |
2002-12-11 | - less qimage<>qpixmap conversions | simon | 1 | -5/+6 |
2002-12-11 | - slight simplification of XineControl constructor | simon | 5 | -18/+37 |
2002-12-11 | - removed unused variable | simon | 1 | -1/+0 |
2002-12-11 | - step three to make it compile with gcc2 | simon | 1 | -0/+1 |
2002-12-11 | - gcc2 is not my friend, given that it can't deal with friend declarations | simon | 2 | -12/+11 |
2002-12-11 | - make it compile for gcc2: step1 | simon | 2 | -10/+9 |
2002-12-11 | - added bool Thread::isRunning() const | simon | 2 | -0/+8 |
2002-12-11 | - make more use of the Resource::* api for loading the data | simon | 1 | -2/+2 |
2002-12-11 | - centralize more of the skin loading code, so it can be factored out later | simon | 4 | -22/+28 |
2002-12-11 | - moved the shared button up/down image variables into the base class | simon | 5 | -22/+16 |
2002-12-11 | - initialized xine in a background thread. much time is still spend in | simon | 5 | -5/+42 |
2002-12-11 | - added initialize states to MediaPlayerState | simon | 6 | -6/+68 |
2002-12-10 | - added an m_initialized flag and a guard for it, along with an | simon | 2 | -1/+71 |
2002-12-10 | - factor out the expensive xine initialization code into a separate method, | simon | 2 | -5/+14 |
2002-12-10 | moving to playlistview after adding to it is annoying some people and me some... | llornkcor | 1 | -2/+6 |
2002-12-10 | - added ThreadUtil::Thread class | simon | 2 | -0/+127 |
2002-12-09 | - ok, next try for that allocator. stupid gcc2 :( | simon | 1 | -1/+12 |
2002-12-09 | - work around gcc2's stupid STL that requires libstdc++ in the default | simon | 1 | -3/+7 |
2002-12-09 | - removed unused isHeld attribute | simon | 1 | -2/+1 |
2002-12-09 | - hah, the improved design pays off :) switching skins at run-time now | simon | 9 | -61/+87 |
2002-12-09 | - the skin loading code is now centralized. no more duplicated code :) | simon | 4 | -48/+50 |
2002-12-09 | - minor cleanup | simon | 4 | -15/+2 |
2002-12-09 | - reworked the mouse event handling to be much simpler | simon | 4 | -47/+51 |
2002-12-09 | - another small cleanup in the mouse handling | simon | 6 | -18/+13 |