summaryrefslogtreecommitdiff
path: root/noncore/multimedia
AgeCommit message (Expand)AuthorFilesLines
2002-12-11- added a skin cache and a threaded skin loader. looks like the lattersimon3-4/+155
2002-12-11- expose information about the buttonssimon4-2/+28
2002-12-11- ah, forgot to remove this unused codesimon1-19/+0
2002-12-11- roll back the threaded xine initialization, the mediaplayer initializationsimon11-241/+84
2002-12-11- less code duplication. code from resizeEvent is now shared as well assimon4-41/+42
2002-12-11- moved default skin name reading over to skin classsimon3-10/+26
2002-12-11- minor cleanupsimon2-7/+5
2002-12-11- oops, do the right cast in the gamma set methodsimon1-1/+1
2002-12-11- slight simplification in the APIsimon4-12/+11
2002-12-11- button mask composing moved to Skin classsimon4-27/+41
2002-12-11- starting with skin preloadingsimon2-6/+37
2002-12-11- moved the remaining pieces of image/pixmap loading to the Skin classsimon4-16/+23
2002-12-11- more image loading functionality moved to the Skin classsimon3-2/+17
2002-12-11- starting to factor out the actual skin image loading into a separatesimon4-3/+48
2002-12-11- less qimage<>qpixmap conversionssimon1-5/+6
2002-12-11- slight simplification of XineControl constructorsimon5-18/+37
2002-12-11- removed unused variablesimon1-1/+0
2002-12-11- step three to make it compile with gcc2simon1-0/+1
2002-12-11- gcc2 is not my friend, given that it can't deal with friend declarationssimon2-12/+11
2002-12-11- make it compile for gcc2: step1simon2-10/+9
2002-12-11- added bool Thread::isRunning() constsimon2-0/+8
2002-12-11- make more use of the Resource::* api for loading the datasimon1-2/+2
2002-12-11- centralize more of the skin loading code, so it can be factored out latersimon4-22/+28
2002-12-11- moved the shared button up/down image variables into the base classsimon5-22/+16
2002-12-11- initialized xine in a background thread. much time is still spend insimon5-5/+42
2002-12-11- added initialize states to MediaPlayerStatesimon6-6/+68
2002-12-10- added an m_initialized flag and a guard for it, along with ansimon2-1/+71
2002-12-10- factor out the expensive xine initialization code into a separate method,simon2-5/+14
2002-12-10moving to playlistview after adding to it is annoying some people and me some...llornkcor1-2/+6
2002-12-10- added ThreadUtil::Thread classsimon2-0/+127
2002-12-09- ok, next try for that allocator. stupid gcc2 :(simon1-1/+12
2002-12-09- work around gcc2's stupid STL that requires libstdc++ in the defaultsimon1-3/+7
2002-12-09- removed unused isHeld attributesimon1-2/+1
2002-12-09- hah, the improved design pays off :) switching skins at run-time nowsimon9-61/+87
2002-12-09- the skin loading code is now centralized. no more duplicated code :)simon4-48/+50
2002-12-09- minor cleanupsimon4-15/+2
2002-12-09- reworked the mouse event handling to be much simplersimon4-47/+51
2002-12-09- another small cleanup in the mouse handlingsimon6-18/+13
2002-12-09- apparently gcc2 is too stupid to grok this :-(simon1-1/+1
2002-12-09- another global variable removedsimon2-3/+3
2002-12-09- yay, mouseMoveEvent is no more duplicated code :)simon6-91/+50
2002-12-09- removing duplicated code in VideoWidgetsimon4-27/+9
2002-12-09- more cleanups in the mouse event handlersimon2-7/+4
2002-12-09- less indexingsimon1-4/+6
2002-12-09- transition to MediaWidget::Command completedsimon5-28/+30
2002-12-09- starting to migrate the videowidget to MediaWidget::Command and friendssimon2-21/+21
2002-12-09- less hardcoding of numberssimon1-4/+5
2002-12-09- back to a vector :Psimon4-17/+19
2002-12-09- less indexing in the mouse event handlersimon2-23/+29
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon5-23/+17