Age | Commit message (Collapse) | Author | Files | Lines |
|
|
|
FIX: It is put in now.
|
|
FIX: The code there is just strange. I tore out the switch statement and
replaced it with a simple if block instead.
|
|
valid.
|
|
In that expansion a whole new crop of unchecked returns has sprung up.
This commit fixes those weeds or should I say potential bugs.
|
|
|
|
some way but never used. This is a tricky problem with Qt since almost all
UI forms are made but not used (like QLabel). But I am pretty confident that
these changes are correct and do not have any aspect of a change to the UI.
In most cases, there are just variables that are made and then copied over
(like in iteration over lists or assignment of pointers based on
conditionals).
|
|
is assumed to be something but no initial value is given.
This commit changes that by either assigning an initial value or removing
the assumption on an initial value (usually the former).
|
|
|
|
using directional buttons and space/enter (which is all that is available on some PDAs if the screen is uncalibrated). In addition, you can now enter numbers using number keys if your device has them.
|
|
appropriate name
|
|
|
|
out code
|
|
|
|
button action to button dialog; show error if user clicks on New without first typing a new name; show error if user clicks New with Remotes as a name
|
|
message if user presses a button that has not been configured
|
|
|
|
|
|
|
|
For TEHistory.cpp, it uses tmpfile() which produces a file which has a
name that can be guessed.
For vmemo.cpp, it uses tmpname() which only creates a predictable string.
Both uses have been switched to using mkstemp() wrapped around umask(). This
produces a much less predictable file that also has guaranteed restrictive
permissions.
I went a little farther in vmemo because it calls out to the shell using
system to 'mv' the new file. That is kinda wasteful so I switched it to use
rename instead.
|
|
that it is expanding. Since strlen() is used with the URLs after Expand
is used, it is good idea to make sure that Expand terminates the strings.
This commit changes that so that the URL strings are guaranteed to be
terminated after expansion.
|
|
|
|
'reverse inull'. All that means is that a pointer gets dereferenced. Then
a pointer gets checked for validity before being dereferenced again. This
almost always points to shenanigans.
For example, the konsole.cpp file has this konsoleInit() call which passes
in a const char** shell variable. Since it is a double pointer the programmer
who wrote the code made the mistake of mixing the checking of the pointer
and the pointer that points to the pointer. This commit attempts to correct
that.
Of course there are other instances of the same thing. But they all boil
down to a small mistake which might have produced strange side effects.
|
|
One of them was introduced in my memory leak fixing (whoops). I was freeing
a structure of stock data before one last call to it. So switching the free
to after that call fixed it.
The kcheckers.cpp fix is one where the game board could be deleted and then
a new one is not created because someone attempted to request a game board
type that is not supported. This is fixed by using the default directive for
one of the game board types in the switch statement. Which means it could
default to Russian boards. Score one for the Russians!
|
|
the file more readable (and smaller overall).
|
|
overrun static buffers. This could lead to serious problems. Granted it
is almost impossible to do that. But it isn't totally impossible. So this
commit makes it impossible to overrun.
|
|
negative result but the result is used in a context that can only be
positive.
|
|
one point in the code and then not checked in another point in the code.
If it needed to be checked once, it needs to be checked the other time. If not
the application could segfault.
|
|
never traversed because of conditionals operating on values that
never change.
|
|
all of them are minor and should not effect properly running code. But if I
were you I would give libstocks and the stockticker plugin in Today a wide
berth. That library is atrocious.
|
|
|
|
a null value for a pointer and that null value was not checked.
|
|
Each file also didn't check the return value.
This commit changes it so that every single non-checked call in these files
is checked.
|
|
that were dup'ed.
noncore/apps/opie-reader/Bkmks.cpp deletes a temporary pointer that
was not being properly disposed of.
|
|
|
|
allocated in the constructor but not de-allocated in the destructor.
This commit fixes that.
|
|
FIX: Fix the number used in memset.
|
|
/usr/share/zoneinfo for the selected time zone is missing
|
|
where the date/time slips or is reset when the device is reset)
|
|
Partially fixes bug #1618.
|
|
* Improve usability of snooze function (fixes bug #1598)
* Fix stretched icon (fixes bug #1616)
|
|
specified file already exists; change tab to show filename when saving a new file
|
|
allowing the OK/Cancel buttons on the dialog to be shown.
Fixes bug #1373.
|
|
|
|
|
|
already provided by libkate.
Fixes bug #1231.
|
|
|
|
(Qt bug?)
|
|
server.
|
|
|