summaryrefslogtreecommitdiff
path: root/x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild
authorMichael Krelin <hacker@klever.net>2007-02-21 01:16:18 (UTC)
committer Michael Krelin <hacker@klever.net>2007-02-21 01:16:18 (UTC)
commitb3277651c9c02a910e384b6633bf4b1915e6302a (patch) (side-by-side diff)
tree255e8eb73dafaeeab6053bd99ff26b9ce73d529c /x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild
parent7232b0256da0c1b1577ce3bf55868d74f36f4dd4 (diff)
downloadmisc-b3277651c9c02a910e384b6633bf4b1915e6302a.zip
misc-b3277651c9c02a910e384b6633bf4b1915e6302a.tar.gz
misc-b3277651c9c02a910e384b6633bf4b1915e6302a.tar.bz2
fvwmkb added
Diffstat (limited to 'x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild b/x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild
new file mode 100644
index 0000000..87811af
--- a/dev/null
+++ b/x11-plugins/fvwmkb/fvwmkb-0.3.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+DESCRIPTION="A keyboard layout switcher module for fvwm window manager"
+HOMEPAGE="http://sourceforge.net/projects/fvwmkb/"
+SRC_URI="mirror://sourceforge/fvwmkb/FvwmKb-${PV}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+RDEPEND="x11-wm/fvwm"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+"
+
+S=${WORKDIR}/FvwmKb-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-moduledir="$(fvwm-config -m)" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install () {
+ dodir `fvwm-config -m`
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog INSTALL INSTALL.FvwmKb INSTALL.FvwmKb.koi8 NEWS README README.koi8 TODO doc/*.sample
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins pixmaps/*.xpm
+}