Age | Commit message (Expand) | Author | Files | Lines |
2002-12-09 | - merged duplicated setToggleButton method | simon | 6 | -17/+12 |
2002-12-09 | - minor cleanup in paintEvent | simon | 2 | -5/+10 |
2002-12-09 | - minor cleanup | simon | 2 | -5/+8 |
2002-12-09 | - merged the duplicated (and identical) paintEvent methods into the | simon | 6 | -52/+30 |
2002-12-09 | - pixBg is now backgroundPixmap and shared in the base class | simon | 5 | -15/+15 |
2002-12-09 | - paintButton is no more a duplicated method but centralized in the | simon | 6 | -28/+14 |
2002-12-09 | - removed unused pixmaps array | simon | 1 | -1/+0 |
2002-12-09 | - getting rid of the buttonPixUp/Down arrays, reuse the Button structure | simon | 2 | -22/+12 |
2002-12-09 | - get rid of the masks array and re-use the Button structure | simon | 2 | -14/+10 |
2002-12-09 | - migrating from a button vector to a button map | simon | 3 | -17/+18 |
2002-12-09 | - merged the two button setup loops | simon | 1 | -10/+8 |
2002-12-09 | - merged the separate mask and pixmap arrays into the Button structure | simon | 2 | -19/+15 |
2002-12-09 | - moving some variables to the base class | simon | 2 | -6/+7 |
2002-12-09 | - oops, buttonType is a bad name for a variable, given its redundancy | simon | 3 | -7/+7 |
2002-12-09 | - re-organizing a bit the button storage. more to come. | simon | 2 | -21/+28 |
2002-12-09 | - isToggle is now an enum ButtonType { NormalButton, ToggleButton }; | simon | 3 | -13/+10 |
2002-12-09 | - another hardcoded number removed :) | simon | 1 | -1/+1 |
2002-12-09 | - buttonPixUp/Down are now vectors, too | simon | 2 | -18/+10 |
2002-12-09 | - use a vector to store the masks | simon | 2 | -11/+12 |
2002-12-09 | - one global variable less | simon | 2 | -4/+4 |
2002-12-09 | switch (mouse) { | simon | 1 | -4/+4 |
2002-12-09 | - replaced currentFileListView method with a variable | simon | 2 | -17/+12 |
2002-12-09 | - use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE and | simon | 3 | -8/+4 |
2002-12-09 | - Key_Space triggers togglePaused() | simon | 1 | -9/+1 |
2002-12-08 | - synchronizing the button indices a bit more with the audiowidget | simon | 2 | -6/+6 |
2002-12-08 | - merged the two duplicated toggleButton methods into a shared one | simon | 6 | -17/+9 |
2002-12-08 | - oops, forgot to commit this one | simon | 1 | -0/+6 |
2002-12-08 | - some preparations for further code cleanups for paintButton calls | simon | 5 | -14/+17 |
2002-12-08 | - moved the duplicated code for checking whether the mouse is over a | simon | 4 | -12/+12 |
2002-12-08 | - merged xoff/yoff into a QPointe member variable, shared in the base class | simon | 5 | -17/+17 |
2002-12-08 | - made XineControl independent from VideoWidget | simon | 3 | -12/+11 |
2002-12-08 | - share the imgButtonMask member variable in the base class | simon | 5 | -14/+14 |
2002-12-08 | - no need to include audio and videowidget.h here | simon | 1 | -2/+0 |
2002-12-08 | - share the buttons data in a buttons member variable in the base class | simon | 5 | -50/+48 |
2002-12-08 | - #include cleanup | simon | 1 | -7/+0 |
2002-12-08 | - I'm re-using code from the others, so add their copyright :) | simon | 2 | -0/+6 |
2002-12-08 | - unused variables removed | simon | 3 | -39/+1 |
2002-12-08 | - made audioButtons a member variable here, too | simon | 2 | -4/+26 |
2002-12-08 | - made videoButtons a member variable instead of a global one | simon | 3 | -5/+29 |
2002-12-08 | - merged duplicated MediaButton definition into common MediaWidget::Button | simon | 3 | -9/+13 |
2002-12-08 | - minor cleanup | simon | 2 | -10/+15 |
2002-12-08 | - properly shut down xine in the destructor. fixes crashes when switching | simon | 1 | -0/+7 |
2002-12-08 | - when the file list view is visible only enable the play button if there | simon | 3 | -0/+40 |
2002-12-05 | - adapted to xine CVS HEAD | simon | 2 | -32/+37 |
2002-12-05 | - fixed a minor memory leak | simon | 1 | -9/+8 |
2002-12-05 | - turned if ( foo ) delete foo; into straight delete foo; as the if is | simon | 2 | -11/+8 |
2002-12-05 | damn.. wrong thing hehe | llornkcor | 1 | -1/+1 |
2002-12-05 | trying to keep up with tronical.. just removed unused parameters. | llornkcor | 2 | -2/+2 |
2002-12-04 | - scanForAudio and scanForVideo is scanFiles in the file list view, so | simon | 2 | -13/+2 |
2002-12-04 | - scannedFiles is no more public | simon | 2 | -20/+4 |