summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2008-01-05 21:43:51 (UTC)
committer Michael Krelin <hacker@klever.net>2008-01-05 22:03:55 (UTC)
commita0719fb611507d8b9962b87c600855d8837fc266 (patch) (side-by-side diff)
treec4d2252f876dfdaf71f41affc5a2324762eca84e /configure.ac
parent7bde7f66284b47a75bbceadc360e7f03550ace21 (diff)
downloadlibopkele-a0719fb611507d8b9962b87c600855d8837fc266.zip
libopkele-a0719fb611507d8b9962b87c600855d8837fc266.tar.gz
libopkele-a0719fb611507d8b9962b87c600855d8837fc266.tar.bz2
added htmltidy dependency
- added libtidy detection to configure - added tidy flags to libopkele.pc.in - added primitive wrapper classes - added tidy exception class Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51bacd5..5772ead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,19 @@ AC_CHECK_HEADER([expat.h],[
AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
])
+AC_CHECK_HEADER([tidy.h],[
+ AC_CHECK_LIB([tidy],[tidyParseBuffer],[
+ TIDY_LIBS=-ltidy
+ TIDY_CFLAGS=
+ AC_SUBST([TIDY_LIBS])
+ AC_SUBST([TIDY_CFLAGS])
+ ],[
+ AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
+ ])
+],[
+ AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
+])
+
if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
AC_SUBST([PCRE_CFLAGS])
AC_SUBST([PCRE_LIBS])