summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51bacd5..5772ead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,19 @@ AC_CHECK_HEADER([expat.h],[
AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
])
+AC_CHECK_HEADER([tidy.h],[
+ AC_CHECK_LIB([tidy],[tidyParseBuffer],[
+ TIDY_LIBS=-ltidy
+ TIDY_CFLAGS=
+ AC_SUBST([TIDY_LIBS])
+ AC_SUBST([TIDY_CFLAGS])
+ ],[
+ AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
+ ])
+],[
+ AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.nt/])
+])
+
if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
AC_SUBST([PCRE_CFLAGS])
AC_SUBST([PCRE_LIBS])