summaryrefslogtreecommitdiff
path: root/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
Side-by-side diff
Diffstat (limited to 'www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild b/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
new file mode 100644
index 0000000..e6fee7a
--- a/dev/null
+++ b/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils apache-module
+
+DESCRIPTION="FastCGI is a language independent, scalable, open extension to CGI that provides high performance without the limitations of server specific APIs."
+KEYWORDS="amd64 ppc sparc x86"
+SLOT="0"
+HOMEPAGE="http://fastcgi.com/"
+SRC_URI="http://fastcgi.com/dist/${P}.tar.gz"
+LICENSE="mod_fastcgi"
+
+APXS1_ARGS="-c mod_fastcgi.c fcgi*.c"
+APXS2_ARGS="${APXS1_ARGS}"
+
+APACHE1_MOD_CONF="20_mod_fastcgi"
+APACHE2_MOD_CONF="20_mod_fastcgi"
+
+APACHE1_MOD_DEFINE="FASTCGI"
+APACHE2_MOD_DEFINE="FASTCGI"
+
+DOCFILES="CHANGES README docs/LICENSE.TERMS docs/mod_fastcgi.html"
+
+need_apache
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-apache-2.2.patch
+}