summaryrefslogtreecommitdiff
path: root/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
Unidiff
Diffstat (limited to 'www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild b/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
new file mode 100644
index 0000000..e6fee7a
--- a/dev/null
+++ b/www-apache/mod_fastcgi/mod_fastcgi-2.4.2-r2.ebuild
@@ -0,0 +1,31 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils apache-module
6
7DESCRIPTION="FastCGI is a language independent, scalable, open extension to CGI that provides high performance without the limitations of server specific APIs."
8KEYWORDS="amd64 ppc sparc x86"
9SLOT="0"
10HOMEPAGE="http://fastcgi.com/"
11SRC_URI="http://fastcgi.com/dist/${P}.tar.gz"
12LICENSE="mod_fastcgi"
13
14APXS1_ARGS="-c mod_fastcgi.c fcgi*.c"
15APXS2_ARGS="${APXS1_ARGS}"
16
17APACHE1_MOD_CONF="20_mod_fastcgi"
18APACHE2_MOD_CONF="20_mod_fastcgi"
19
20APACHE1_MOD_DEFINE="FASTCGI"
21APACHE2_MOD_DEFINE="FASTCGI"
22
23DOCFILES="CHANGES README docs/LICENSE.TERMS docs/mod_fastcgi.html"
24
25need_apache
26
27src_unpack() {
28 unpack ${A}
29 cd ${S}
30 epatch ${FILESDIR}/${P}-apache-2.2.patch
31}