summaryrefslogtreecommitdiff
path: root/app-pda/makeztxt/makeztxt-1.60.ebuild
authorMichael Krelin <hacker@klever.net>2007-04-16 21:06:52 (UTC)
committer Michael Krelin <hacker@klever.net>2007-04-16 21:06:52 (UTC)
commitc485564f09642aefcfa2ec23ac887589f7dc1843 (patch) (side-by-side diff)
treed8e455cf026d9e5faf9bf08c4cd0d63167bee30d /app-pda/makeztxt/makeztxt-1.60.ebuild
parent2ae8ba67d6f323d3678af8b2918cd757ca13a447 (diff)
downloadmisc-c485564f09642aefcfa2ec23ac887589f7dc1843.zip
misc-c485564f09642aefcfa2ec23ac887589f7dc1843.tar.gz
misc-c485564f09642aefcfa2ec23ac887589f7dc1843.tar.bz2
app-pda/makeztxt: make 32bits on amd64
Diffstat (limited to 'app-pda/makeztxt/makeztxt-1.60.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--app-pda/makeztxt/makeztxt-1.60.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-pda/makeztxt/makeztxt-1.60.ebuild b/app-pda/makeztxt/makeztxt-1.60.ebuild
index 08e75ee..164114f 100644
--- a/app-pda/makeztxt/makeztxt-1.60.ebuild
+++ b/app-pda/makeztxt/makeztxt-1.60.ebuild
@@ -11,9 +11,21 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64"
IUSE=""
-DEPEND="sys-libs/zlib"
+RDEPEND="
+ sys-libs/zlib
+ amd64? ( app-emulation/emul-linux-x86-baselibs )
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack $A
+ cd "$S"
+ epatch "${FILESDIR}/${P}-cflags.patch"
+}
src_compile() {
+ CFLAGS="${CFLAGS} $(use amd64 && echo -m32)" \
+ LIBS="${LIBS} $(use amd64 && echo -m32)" \
emake || die "emake failed"
}