summaryrefslogtreecommitdiff
path: root/app-pda/makeztxt/makeztxt-1.60.ebuild
Side-by-side diff
Diffstat (limited to 'app-pda/makeztxt/makeztxt-1.60.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--app-pda/makeztxt/makeztxt-1.60.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/app-pda/makeztxt/makeztxt-1.60.ebuild b/app-pda/makeztxt/makeztxt-1.60.ebuild
index 08e75ee..164114f 100644
--- a/app-pda/makeztxt/makeztxt-1.60.ebuild
+++ b/app-pda/makeztxt/makeztxt-1.60.ebuild
@@ -11,9 +11,21 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64"
IUSE=""
-DEPEND="sys-libs/zlib"
+RDEPEND="
+ sys-libs/zlib
+ amd64? ( app-emulation/emul-linux-x86-baselibs )
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack $A
+ cd "$S"
+ epatch "${FILESDIR}/${P}-cflags.patch"
+}
src_compile() {
+ CFLAGS="${CFLAGS} $(use amd64 && echo -m32)" \
+ LIBS="${LIBS} $(use amd64 && echo -m32)" \
emake || die "emake failed"
}