Age | Commit message (Expand) | Author | Files | Lines |
2002-12-09 | - more cleanups in the mouse event handler | simon | 2 | -7/+4 |
2002-12-09 | - less indexing | simon | 1 | -4/+6 |
2002-12-09 | - transition to MediaWidget::Command completed | simon | 5 | -28/+30 |
2002-12-09 | - starting to migrate the videowidget to MediaWidget::Command and friends | simon | 2 | -21/+21 |
2002-12-09 | - less hardcoding of numbers | simon | 1 | -4/+5 |
2002-12-09 | - back to a vector :P | simon | 4 | -17/+19 |
2002-12-09 | - less indexing in the mouse event handler | simon | 2 | -23/+29 |
2002-12-09 | - toggleButton and setToggleButton now operate on a Button object instead | simon | 5 | -23/+17 |
2002-12-09 | - merged duplicated setToggleButton method | simon | 6 | -17/+12 |
2002-12-09 | APs and adhoc stations are now grouped and displayed as belonging to a common | mickeyl | 4 | -15/+45 |
2002-12-09 | - minor cleanup in paintEvent | simon | 2 | -5/+10 |
2002-12-09 | - minor cleanup | simon | 2 | -5/+8 |
2002-12-09 | - merged the duplicated (and identical) paintEvent methods into the | simon | 6 | -52/+30 |
2002-12-09 | - pixBg is now backgroundPixmap and shared in the base class | simon | 5 | -15/+15 |
2002-12-09 | - paintButton is no more a duplicated method but centralized in the | simon | 6 | -28/+14 |
2002-12-09 | - removed unused pixmaps array | simon | 1 | -1/+0 |
2002-12-09 | - getting rid of the buttonPixUp/Down arrays, reuse the Button structure | simon | 2 | -22/+12 |
2002-12-09 | - get rid of the masks array and re-use the Button structure | simon | 2 | -14/+10 |
2002-12-09 | - migrating from a button vector to a button map | simon | 3 | -17/+18 |
2002-12-09 | - merged the two button setup loops | simon | 1 | -10/+8 |
2002-12-09 | - merged the separate mask and pixmap arrays into the Button structure | simon | 2 | -19/+15 |
2002-12-09 | - moving some variables to the base class | simon | 2 | -6/+7 |
2002-12-09 | small fixes. | mickeyl | 3 | -1/+3 |
2002-12-09 | Wellenreiter is now fully integrated into the Opie build environment. | mickeyl | 10 | -11/+51 |
2002-12-09 | - oops, buttonType is a bad name for a variable, given its redundancy | simon | 3 | -7/+7 |
2002-12-09 | - re-organizing a bit the button storage. more to come. | simon | 2 | -21/+28 |
2002-12-09 | - isToggle is now an enum ButtonType { NormalButton, ToggleButton }; | simon | 3 | -13/+10 |
2002-12-09 | - another hardcoded number removed :) | simon | 1 | -1/+1 |
2002-12-09 | - buttonPixUp/Down are now vectors, too | simon | 2 | -18/+10 |
2002-12-09 | - use a vector to store the masks | simon | 2 | -11/+12 |
2002-12-09 | - one global variable less | simon | 2 | -4/+4 |
2002-12-09 | switch (mouse) { | simon | 1 | -4/+4 |
2002-12-09 | - replaced currentFileListView method with a variable | simon | 2 | -17/+12 |
2002-12-09 | - use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE and | simon | 3 | -8/+4 |
2002-12-09 | - Key_Space triggers togglePaused() | simon | 1 | -9/+1 |
2002-12-08 | Fixed saving of new checkbooks and incorrect setting of notes. | drw | 2 | -1/+7 |
2002-12-08 | - synchronizing the button indices a bit more with the audiowidget | simon | 2 | -6/+6 |
2002-12-08 | - switched from inlined logo to png | mickeyl | 2 | -1066/+23 |
2002-12-08 | removed some clumsy workarounds for old (unpatched) libqte's | sandman | 1 | -12/+3 |
2002-12-08 | - merged the two duplicated toggleButton methods into a shared one | simon | 6 | -17/+9 |
2002-12-08 | - oops, forgot to commit this one | simon | 1 | -0/+6 |
2002-12-08 | - some preparations for further code cleanups for paintButton calls | simon | 5 | -14/+17 |
2002-12-08 | - moved the duplicated code for checking whether the mouse is over a | simon | 4 | -12/+12 |
2002-12-08 | - merged xoff/yoff into a QPointe member variable, shared in the base class | simon | 5 | -17/+17 |
2002-12-08 | - made XineControl independent from VideoWidget | simon | 3 | -12/+11 |
2002-12-08 | - share the imgButtonMask member variable in the base class | simon | 5 | -14/+14 |
2002-12-08 | - no need to include audio and videowidget.h here | simon | 1 | -2/+0 |
2002-12-08 | - share the buttons data in a buttons member variable in the base class | simon | 5 | -50/+48 |
2002-12-08 | - #include cleanup | simon | 1 | -7/+0 |
2002-12-08 | - I'm re-using code from the others, so add their copyright :) | simon | 2 | -0/+6 |